Génération mobiles - Forum smartphones & tablettesConnexion

Forum Android pour smartphones & tablettes Asus, HTC, Huawei, Honor, LG, Nokia, OnePlus, Samsung, Sony, Xiaomi... Retrouvez applications, astuces, aide, jeux, tutos,...

[Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

mode_editPoster un nouveau sujetreplyRépondre au sujet
Partagez

description[Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz

Xposed Framework



Introduction

Veuillez noter que le Xposed framework modifie beaucoup de choses sensibles, il est donc recommandé de faire un nandroid backup avant de l'installer.

- Android 4.4 (KitKat) ou inférieur -
Allez directement aux versions stables ICI.


Téléchargements - Version officielle rovo89

Regardez le post 2 si vous cherchez Xposed pour Samsung ou MIUI ou pour du systemless

XposedInstaller_3.1.4.apk doit être installé pour gérer les modules, le framework ne fonctionnera pas lui.

Le téléchargement du Xposed framework se fait via l'application désormais, plus besoin de recovery custom pour l'installer.
Au cas où, vous pouvez télécharger les fichiers ZIP flashables depuis cet endroit.


xposed-uninstaller*.zip peut être flashé depuis un recovery custom (TWRP) pour désinstaller le framework.


Problèmes connus

• Redémarrages en boucle sur les ROMs Stock Samsung (à cause de modifications faites par Samsung sur ART). Il existe des versions non officielles qui contournent le problème en dédodexant la ROM (voir liens en début de post)
• Sony semble avoir intégré dans certaines ROMs des services.odex corrompus (le .dex embarqué est invalide). Ces ROMs redémarreront en boucle avec une erreur "Fatal signal 6" ou "No pending exception expected: java.lang.ArrayIndexOutOfBoundsException". Non résolvable actuellement.
• Puces Dell : voir ici.

Autres liens

Informations API / SDK Android
Sujet de discussion XDA - Nougat
Sujet de discussion XDA - Marshmallow
Sujet de discussion XDA - Lollipop
Source

Dernière édition par Primokorn le Mar 9 Jan 2018 - 10:02, édité 40 fois

descriptiontélécharger xposed framework, xposed lollipop, xposed marshmallow, rovo, xposed nougat, modules

more_horiz

Versions non officielles

Si vous cherchez un Xposed spécifique (Samsung, MIUI, Systemless,...) alors faites vos recherches sur XDA.

Dernière édition par Primokorn le Mer 18 Oct 2017 - 15:47, édité 5 fois

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Réservé

Dernière édition par Primokorn le Mer 28 Sep 2016 - 10:00, édité 1 fois

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci de l'info

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Petit retour pour Xposed sur Android 5.1 (ROM Dirty Unicorns).
Par rapport à la version pour Android 5.0, rien de spécial à noter sur l'interface ou les options. J'ai sélectionné plusieurs modules connus pour fonctionner et tout roule.
Le premier démarrage prend toujours autant de temps.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour de Xposed pour Android 5.0.x

Nouveau zip flashable téléchargeable dans le post 1 : xposed-sdk21-arm-20150426.zip
Vous devez uniquement flasher ce zip, l'application Xposed Installer reste la même (et affichera donc la version alpha2). Si XposedBridge.jar a la version 64 après redémarrage, alors la nouvelle version est activée.

Changelog :
• problèmes avec le remplacement de drawables corrigé
• correctif de NoSuchMethodError dans handleInitPackageResources
• Possibles correctifs de certaines erreurs sur des ROMs qui se lancement en mode SELinux permissif et basculent sur le mode appliqué.

► Non compatible avec Android 5.1 pour le moment
► Processeurs arm64/x86 non supportés

Pour les ROMs Samsung : aucun avancement. Pas sûr qu'elles soient supportées un jour.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Hello

Le non support possible des roms Samsung est une très mauvaise nouvelle.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci de l'info, je flash de suite.

Bonne journée

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour 5.0 :
Correction bootloop et plantage sur certaines roms, notamment sur les appareils Sony.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci pour le suivi

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Nouvelle version pour Android 5.1.x
=> xposed-sdk22-5.1.0-arm-20150514.zip
=> xposed-sdk22-5.1.1-arm-20150514.zip

Correction de bugs de bootloops et plantages avec les modules

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci,

Si je ne me trompe pas, ce sont des versions 32bits donc pas pour les appareils en ARM 64 bits?

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Oui, toujours du 32bit.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Nouvelle mise à jour pour Android 5.1, support arm64 désormais :

=> xposed-sdk22-arm-20150514.zip
=> xposed-sdk22-arm64-20150514.zip

Presque tout le monde doit télécharger la version ARM. Utilisez la version ARM64 SEULEMENT pour les appareils arm64 (les plus connus sont le HTC One 9 et la Nexus 9). Faites une recherche sur Google ou dans votre build.prop pour trouver la réponse en cas de doute.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Good news,

Merci pour ces infos Wink

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
A ce sujet, Primokorn, j'ai flashé la version xposed-sdk22-arm-20150514.zip et j'ai en permanence, dès le reboot, un message qui me dit que je n'ai plus de place, stockage limité, blabla.
Bref, sur la Terminus, cette version ne passe pas.
J'ai dû remettre un backup Sad
Galère car j'aimerais bien mettre Xprivacy...
Sais-tu si c'est la Terminus qui serait incompatible ?

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
As-tu fais un wipe dalvik cache après avoir flashé le fichier ? Si oui alors la Terminus modifie le build.prop.

Problème connu avec la Chroma. À voir si cette solution marche avec la Terminus.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Oui, j'ai fait le Wipe Dalvik Cache
Merci, je vais tester ça smile

EDIT : Nickel, la mise en commentaire des deux lignes permet de ne plus avoir ce message d'espace de stockage saturé.
Sais-tu si Xprivacy a été mis à jour pour la 5.1 ?

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Réponse Xposed pour les amis Samsung

@db77 a écrit:
Oui, j'ai fait le Wipe Dalvik Cache
Merci, je vais tester ça smile

EDIT : Nickel, la mise en commentaire des deux lignes permet de ne plus avoir ce message d'espace de stockage saturé.
Sais-tu si Xprivacy a été mis à jour pour la 5.1 ?

Oui mais Xposed n'a pas assez stable pour que Xprivacy fonctionne correctement. La dernière version arm permet d'utiliser la version 3.6.6 normalement. Faut être en permissif par contre Sad

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Grrr... Espérons que tout cela va finir par s'arranger car j'ai dû réhabiliter mon Desire HD qui est sous 4.4 et faire un hotspot avec mon Nexus 5 pour qu'il s'y connecte...
Cela m'éviterait d'avoir à utiliser deux téléphones ...

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
C'est pas pour demain malheureusement... Sinon, pourquoi tu fais ce hotspot ?

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Car c'est plus facile pour moi plutôt que de retirer ma SIM du Nexus 5 pour la mettre dans le HTC Desire HD avec un adaptateur et vice-versa ensuite, vu que j'ai besoin de la data.
EDIT : MP envoyé

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Installation sans souci sur le M8...

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
C'est pas l'installation qui pose problème (sauf Samsung) En tout cas, la dernière mise à jour Xposed 5.1 a fait beaucoup de bien aux modules Very Happy

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Ajout partie "Utilisateurs Samsung" pour Android 5.0 et 32-bit uniquement.
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum
reply