Génération mobiles - Forum smartphones & tablettesConnexion

Forum Android pour smartphones & tablettes Asus, HTC, Huawei, Honor, LG, Nokia, OnePlus, Samsung, Sony, Xiaomi... Retrouvez applications, astuces, aide, jeux, tutos,...

[Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

mode_editPoster un nouveau sujetreplyRépondre au sujet
Partagez

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Cela vient tout doucement...

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
@Primokorn a écrit:
C'est pas l'installation qui pose problème (sauf Samsung) En tout cas, la dernière mise à jour Xposed 5.1 a fait beaucoup de bien aux modules Very Happy


C'est vrai avec la bonne version tout va bien smile... pour 5.1 je ne sais pas, je suis toujours en 5.01

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour 5.1 ICI

Changelog
- Xposed: fixed xposed not writing to log on some devices (useful mainly for module developers)
- ART: potential fix for debugger crash when debugging hooked methods
- ART: fixed modules crashing on launch right after they get updated
- ART: ignore unknown arguments passed to dex2oat,oatdump,patchoat and runtime (potentially improves compatibility with OEM ROMs)
- ART: added gzip support to patchoat to potentially improve compatibility with CM-based ROMs (cherry-picked from CyanogenMod version of ART)

ARM version has been tested on Nexus 5
ARM64 version is untested

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
ARM64 version is untested Sad 

Merci quand même smile

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Pour les utilisateurs des ROMs Temasek / arter97, testez cette version.
(vous avez normalement un bootloop avec le Xposed 5.1.1 "officiel")

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour Android 5.1.1 non officielle de la version non officielle smile

=> xposed-sdk22-arm-20150624.zip
=> xposed-sdk22-arm64-20150624.zip

Source

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
:merci: Wink

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
:merci:
J'adore le "non officielle de la version non officielle" Wink

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
smile On arrive à s'y perdre. Depuis la première version non officielle Android 5.1, 3 personnes proposent des mises à jour. Heureusement qu'ils sont là.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour de la dernière mise à jour non officielle non officielle smile

xposed-sdk22-multiarch-20150626.zip

Source
Si vous avez déjà flashé la version précédente, il est inutile de reflasher celle-ci. C'est le mode d'installation qui change (Exemple : un seul fichier pour ARM et ARM64 et x86 (32 et 64)).

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
:merci:

Je regarderai cela un peu plus tard ...

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à officielle Android 5.0

Elle inclut des modifications & améliorations ainsi que des correctifs.

Pour éviter les confusions, il existe maintenant 2 numéros de version :
► le zip du framework (tous les fichies dans le fichier à flasher) est incrémenté avec des nombres entiers (69 pour cette mise à jour). Les versions non officielles devraient utiliser des décimales pour les versions.
► l'application Xposed Installer restent sur un format 3.0 alpha3 par exemple.

Nouveau script d'installation.
ZIPs de désinstallation à flasher. Ils annulent toutes les actions faites par le script d'installation. Uniquement testées sur Android 5.0.

Les autres modifs techniques :
- Installer: Display the installed framework version in green, instead of a static hint about flashing the framework via recovery.
- Fix for incomplete logs on some devices, see https://github.com/rovo89/Xposed/issues/34
- Fix for updated modules crashing until the next reboot, see https://github.com/rovo89/Xposed/issues/22
- Ignore unknown parameters to avoid bootloops on some devices, see https://github.com/rovo89/android_art/issues/7
- Some other internal improvements
- Some cherry-picked ART commits from AOSP
- Devs: Allow hooking native methods, see https://github.com/rovo89/Xposed/issues/28
- Devs: Several debugger fixes, see https://github.com/rovo89/android_art/issues/1


Les builds pour arm64 et x86 ont aussi été mises à jour.

Le support officiel de Android 5.1 va arriver prochainement ou plus tard, mais les modifications ci-dessus nécessitent une phase de débogage, de développement et de réflexion.







descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci pour toutes ces précisions

Je me demande si on devrai "épingler" ce topic d'ailleurs...

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Comme tu le sens smile

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Nouvelle mise à jour pour Android 5.1 Very Happy (liée à la mise à jour officielle de rovo89)

ATTENTION : pour utiliser cette version, vous devez aussi prendre la version non officielle de Xposed Installer, qui corrige un petit bug de l'appli officielle (Xposed pas actif, avertissements,...)
Vous devez donc désinstaller la version officielle Xposed Installer avant d'installer celle-ci !
Backup recommandé avant toute mise à jour.

xposed-sdk22-arm-20150629.zip
xposed-sdk22-arm64-20150629.zip
XposedInstaller_3.0_alpha3_unofficial.apk

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci, smile

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour officielle non officielle Android 5.1

xposed-uninstaller-arm.zip
xposed-uninstaller-arm64.zip
xposed-uninstaller-x86.zip
xposed-v65-sdk22-arm-by-romracer-20150629.zip
xposed-v65-sdk22-arm64-by-romracer-20150629.zip
xposed-v65-sdk22-x86-by-romracer-20150629.zip

Mise à jour v65 selon rovo89 et utiliser la version 3.0 ALPHA4 de Xposed Installer.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour d'hier :
Updated installer and uninstaller again. Installer is now less complex but still works on devices with low /system space. If you had no problems installing previous releases, then there's no need to update to this version. Uninstaller is backward compatible. See this commit for details.

Vu le nombre de mises à jour en ce moment par rapport aux retours sur le forum, je renvois le téléchargement à la source.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour Xposed framework pour Samsung !

xposed-v65-sdk21-arm-arter97-V5-generic.zip
xposed-v65-sdk21-arm-arter97-V5-krait.zip

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Bonsoir Primokorn,
Tes liens pour Samsung, c'est pour LP 5.0 ou 5.1 ? J'ai regardé sur Xda en direct, mais ce n'est pas très clair.
Je cherche une version pour mon GN1, avec une rom LP5.0 Touch Wiz.
Merci

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Bonjour pas&isa,
"sdk21" donc Lollipop 5.0 normalement Wink

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Merci Primokorn.
En plus, je viens de voir que c’était écrit en page 1....

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour Xposed Android 5.0 => v66 et uninstaller.
Pas de changement dans le framework donc pas besoin de faire la mise à jour si vous avez la v65.

Correction des messages "Invalid argument" et "Wrong SDK version: 19, expected 21" lors du flash.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à Jour :

XposedInstaller_3.0_alpha4.apk

Comme nous l'a déjà dit Primo, il faudra choisir parmi tout les fichiers.

A notre niveau moi et mon HTC One M7 voici les fichiers dont j'avais besoin.
Mon appareil est souvent "Réinitialisé" donc j'ai souvent ces fichiers à réinstaller.

  • xposed-v67-sdk21-arm.zip
  • XposedBridgeApi-20150213.jar
  • XposedInstaller_3.0_alpha4.apk
  • xposed-uninstaller-arm.zip


A Savoir :

L'installation est la même.

  1. Téléchargement de tous les fichiers nécessaires
  2. Copier tout les fichiers sur la racine de la carte SD (Carte mémoire)
  3. Installation de XposedInstaller_3.0_alpha4.apk (le programme)
  4. Redémarrage en RECOVERY de l'appareil
  5. Installation du dernier Framework (Si vous vous trompez de fichier, cela n'aura pour ainsi dire aucune incidence sauf faire apparaitre un message d'erreur dans votre Recovery.)
  6. C'est le fichier xposed-v67-sdk21-arm.zip (pour les HTC ONE M7)
  7. Celui-ci ajoutera directement le fichier .jar dont vous devez vous demander l'utilité.

descriptionRe: [Xposed Framework] Installation et informations sur KitKat, Lollipop, Marshmallow, Nougat et Oreo

more_horiz
Mise à jour Android 5.1, pour les les applications chiffrées LG (LGCover, LGWeather,...)
Voir ICI
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum
reply